Corrupted File Retries and Circular Entity Dependencies Causing System Failures

Major incident WEB Console File Management API Data Syncer
2025-08-14 11:00 AM -04 · 1 day, 9 hours, 12 minutes

Updates

Resolved

The system has fully recovered. All pending data has been successfully processed, and all affected services are now operating normally.

August 15, 2025 · 08:03 PM -04
Update

The underlying bugs causing infinite retries and circular entity calls have been resolved. We are now processing all pending data and gradually restoring normal operations across affected systems.

August 15, 2025 · 10:35 AM -04
Issue

We are currently addressing two critical issues impacting system stability: (1) infinite retry loops caused by corrupted file handling, and (2) circular dependencies between Company and Account Plan entities triggering recursive API calls. These issues are causing jobs to get stuck and services to become unresponsive under certain conditions.

August 14, 2025 · 02:40 PM -04

← Back